Re: [DISCUSS] - Move to 2.0.0

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

fpapon-2
Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon <[hidden email]>:
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

sreenivas harshith
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

Benjamin Marwell
I never had issues with it, but there is no module descriptor yet. Thus, it depends on what you mean by "support java9".


   

On Mon, 4 May 2020, 04:40 sreenivas harshith, <[hidden email]> wrote:
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

fpapon

I am using Shiro with a Jdk11 and I never had issues.

We also have a Jenkins job for the build with JDK11 but the target build for the source code still Java 8.

regards,

François
[hidden email]
Le 04/05/2020 à 09:30, Benjamin Marwell a écrit :
I never had issues with it, but there is no module descriptor yet. Thus, it depends on what you mean by "support java9".


   

On Mon, 4 May 2020, 04:40 sreenivas harshith, <[hidden email]> wrote:
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

sreenivas harshith
Some libs were broken from java 9 and above due to java 9 module system and JDK internal APIs restrictions. Just wanted to check if shiro supports Java 9 and above.


On Mon, May 4, 2020 at 1:12 PM +0530, "Francois Papon" <[hidden email]> wrote:

I am using Shiro with a Jdk11 and I never had issues.

We also have a Jenkins job for the build with JDK11 but the target build for the source code still Java 8.

regards,

François
[hidden email]
Le 04/05/2020 à 09:30, Benjamin Marwell a écrit :
I never had issues with it, but there is no module descriptor yet. Thus, it depends on what you mean by "support java9".


   

On Mon, 4 May 2020, 04:40 sreenivas harshith, <[hidden email]> wrote:
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

Brian Demers
I'd love to see the `shiro-all` module go away as part of 2.0, anyone have any objections?

On Mon, May 4, 2020 at 4:32 AM sreenivas harshith <[hidden email]> wrote:
Some libs were broken from java 9 and above due to java 9 module system and JDK internal APIs restrictions. Just wanted to check if shiro supports Java 9 and above.


On Mon, May 4, 2020 at 1:12 PM +0530, "Francois Papon" <[hidden email]> wrote:

I am using Shiro with a Jdk11 and I never had issues.

We also have a Jenkins job for the build with JDK11 but the target build for the source code still Java 8.

regards,

François
[hidden email]
Le 04/05/2020 à 09:30, Benjamin Marwell a écrit :
I never had issues with it, but there is no module descriptor yet. Thus, it depends on what you mean by "support java9".


   

On Mon, 4 May 2020, 04:40 sreenivas harshith, <[hidden email]> wrote:
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

fpapon

+1

François
[hidden email]
Le 07/05/2020 à 00:28, Brian Demers a écrit :
I'd love to see the `shiro-all` module go away as part of 2.0, anyone have any objections?

On Mon, May 4, 2020 at 4:32 AM sreenivas harshith <[hidden email]> wrote:
Some libs were broken from java 9 and above due to java 9 module system and JDK internal APIs restrictions. Just wanted to check if shiro supports Java 9 and above.


On Mon, May 4, 2020 at 1:12 PM +0530, "Francois Papon" <[hidden email]> wrote:

I am using Shiro with a Jdk11 and I never had issues.

We also have a Jenkins job for the build with JDK11 but the target build for the source code still Java 8.

regards,

François
[hidden email]
Le 04/05/2020 à 09:30, Benjamin Marwell a écrit :
I never had issues with it, but there is no module descriptor yet. Thus, it depends on what you mean by "support java9".


   

On Mon, 4 May 2020, 04:40 sreenivas harshith, <[hidden email]> wrote:
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

Benjamin Marwell
+1


   

On Thu, 7 May 2020, 04:13 Francois Papon, <[hidden email]> wrote:

+1

François
[hidden email]
Le 07/05/2020 à 00:28, Brian Demers a écrit :
I'd love to see the `shiro-all` module go away as part of 2.0, anyone have any objections?

On Mon, May 4, 2020 at 4:32 AM sreenivas harshith <[hidden email]> wrote:
Some libs were broken from java 9 and above due to java 9 module system and JDK internal APIs restrictions. Just wanted to check if shiro supports Java 9 and above.


On Mon, May 4, 2020 at 1:12 PM +0530, "Francois Papon" <[hidden email]> wrote:

I am using Shiro with a Jdk11 and I never had issues.

We also have a Jenkins job for the build with JDK11 but the target build for the source code still Java 8.

regards,

François
[hidden email]
Le 04/05/2020 à 09:30, Benjamin Marwell a écrit :
I never had issues with it, but there is no module descriptor yet. Thus, it depends on what you mean by "support java9".


   

On Mon, 4 May 2020, 04:40 sreenivas harshith, <[hidden email]> wrote:
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

fpapon

FYI

https://issues.apache.org/jira/browse/SHIRO-768

regards,

François
[hidden email]
Le 07/05/2020 à 11:44, Benjamin Marwell a écrit :
+1


   

On Thu, 7 May 2020, 04:13 Francois Papon, <[hidden email]> wrote:

+1

François
[hidden email]
Le 07/05/2020 à 00:28, Brian Demers a écrit :
I'd love to see the `shiro-all` module go away as part of 2.0, anyone have any objections?

On Mon, May 4, 2020 at 4:32 AM sreenivas harshith <[hidden email]> wrote:
Some libs were broken from java 9 and above due to java 9 module system and JDK internal APIs restrictions. Just wanted to check if shiro supports Java 9 and above.


On Mon, May 4, 2020 at 1:12 PM +0530, "Francois Papon" <[hidden email]> wrote:

I am using Shiro with a Jdk11 and I never had issues.

We also have a Jenkins job for the build with JDK11 but the target build for the source code still Java 8.

regards,

François
[hidden email]
Le 04/05/2020 à 09:30, Benjamin Marwell a écrit :
I never had issues with it, but there is no module descriptor yet. Thus, it depends on what you mean by "support java9".


   

On Mon, 4 May 2020, 04:40 sreenivas harshith, <[hidden email]> wrote:
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] - Move to 2.0.0

Brian Demers
Thanks Francois!

On Thu, May 7, 2020 at 5:51 AM Francois Papon <[hidden email]> wrote:

FYI

https://issues.apache.org/jira/browse/SHIRO-768

regards,

François
[hidden email]
Le 07/05/2020 à 11:44, Benjamin Marwell a écrit :
+1


   

On Thu, 7 May 2020, 04:13 Francois Papon, <[hidden email]> wrote:

+1

François
[hidden email]
Le 07/05/2020 à 00:28, Brian Demers a écrit :
I'd love to see the `shiro-all` module go away as part of 2.0, anyone have any objections?

On Mon, May 4, 2020 at 4:32 AM sreenivas harshith <[hidden email]> wrote:
Some libs were broken from java 9 and above due to java 9 module system and JDK internal APIs restrictions. Just wanted to check if shiro supports Java 9 and above.


On Mon, May 4, 2020 at 1:12 PM +0530, "Francois Papon" <[hidden email]> wrote:

I am using Shiro with a Jdk11 and I never had issues.

We also have a Jenkins job for the build with JDK11 but the target build for the source code still Java 8.

regards,

François
[hidden email]
Le 04/05/2020 à 09:30, Benjamin Marwell a écrit :
I never had issues with it, but there is no module descriptor yet. Thus, it depends on what you mean by "support java9".


   

On Mon, 4 May 2020, 04:40 sreenivas harshith, <[hidden email]> wrote:
Hi all,

Does shiro support java 9 and above ?

Regards,
Sreenivas.



On Sun, May 3, 2020 at 4:27 PM +0530, <[hidden email]> wrote:

Hi all,

The 1.5.3 is released now, so I created a branch 1.5.x for the
maintenance and move the master to the 2.0.0-SNAPSHOT.

We will now review the 2.0.0 backlog on Jira and merge some ideas from
this thread.

Feel free to create issues related to this next major version and make
proposals / PR:

https://issues.apache.org/jira/projects/SHIRO/versions/12315455

Thanks for all your feedback!

regards,

François
[hidden email]

Le 08/04/2020 à 18:55, Steinar Bang a écrit :
>>>>>> Francois Papon :
>>> It's also time for anyone to bring some ideas about the next Shiro features/improvements, feel free to share :)
> Speaking purely for myself, I would like to see this one fixed:
>  https://issues.apache.org/jira/browse/SHIRO-713